DeepMIMO Forum

Codebook learning (...
Clear all

[Solved] Codebook learning (self-supervised) data generation method  


Jakub Trznadel
 Jakub Trznadel
(@Jakub Trznadel)
Joined: 2 years ago
Posts: 1
21/02/2022 5:17 pm  


I have tried to generate and load the code for example. However, I am struggling. I have tried data sets from both deepmimo v1 and v2, but -still- it seems data format is not matching expected by
Am I doing anything wrong or there is some additional step that I am missing?

Thank you in advance.

Best regards,

Yu Zhang
Member Moderator
Joined: 2 years ago
Posts: 2
23/02/2022 12:20 am  

Hi Jakub,

Thanks for your interest in this paper. Based on your description, I think most likely you didn’t save the generated dataset from DeepMIMO by activating the ‘-v7.3’ flag of the Matlab save funtion. So, if the following error message is similar to what you got:

Traceback (most recent call last):
File "D:\ProgramFiles\Anaconda3\lib\site-packages\h5py\_hl\", line 406, in __init__
fid = make_fid(name, mode, userblock_size,
File "D:\ProgramFiles\Anaconda3\lib\site-packages\h5py\_hl\", line 173, in make_fid
fid =, flags, fapl=fapl)
File "h5py\_objects.pyx", line 54, in h5py._objects.with_phil.wrapper
File "h5py\_objects.pyx", line 55, in h5py._objects.with_phil.wrapper
File "h5py\h5f.pyx", line 88, in
OSError: Unable to open file (file signature not found)

Then, you can try to write ‘-v7.3’ in the Matlab save function, i.e.,

save('your_dataset_name.mat', 'dataset', '-v7.3') % dataset is the variable of your generated channel data


I hope this can solve your problem. Let me know if you still couldn't get the right results.


Good luck,


Muhammad Alrabeiah
 Muhammad Alrabeiah
(@Muhammad Alrabeiah)
Joined: 2 years ago
Posts: 1
03/03/2022 12:33 pm  


I have faced this issue during my first step of downloading the scenario, plz could you tell me what the problem?!

I1 scenario for Mapping channels work. Also, is there an extended work in this research?

Member Admin
Joined: 2 years ago
Posts: 39
18/03/2022 6:50 am  

Hi @Muhammad Alrabeiah,

The download of the large file may occasionally fail. If that happened, the downloaded data is erroneous and you may see such errors.
You may try to re-download through the scenario page. Also, you may use this alternative link for I1_2p5, where each file is separately available and you can download in parts if needed.



Leave a reply

Author Name

Author Email

Title *

Maximum allowed file size is 10MB

Preview 0 Revisions Saved